Laserbrain Studios

Games Forum Blog Contact

Author Topic: No music (Yeah, sdl instaled as music placed on the dir)  (Read 2993 times)

vladimir

  • Guest
That is weird, as I installed asciisec as always. I installed SDL SDL-mixer, downloaded the *.ogg files, and placed them on the music folder. Yet there is no music. I checked with mplayer, and I can perfectly listen/dance whatever to them. There are no warnings on the terminal, so I can only guess there is some kind of obscure dependency not meet on the "readme".

What can I do? I am using Gentoo with 3.4.2 Kernel; guessing if that info can help somehow.

Cheers

Liberty Cruiser

  • Experienced
  • *****
  • Posts: 94
    • View Profile
Re: No music (Yeah, sdl instaled as music placed on the dir)
« Reply #1 on: June 24, 2012, 08:19:16 PM »
Are you sure you extracted them properly and put the individual .ogg files in the music folder? Try going into the game options and checking whether the music volume is muted or not either.

Cthulhu

  • Ace
  • *****
  • Posts: 1371
    • View Profile
Re: No music (Yeah, sdl instaled as music placed on the dir)
« Reply #2 on: June 25, 2012, 09:06:42 AM »
And has the game worked with that version of SDL (mixer) previously, or did you compile a new version?

vladimir

  • Guest
Re: No music (Yeah, sdl instaled as music placed on the dir)
« Reply #3 on: September 30, 2012, 12:40:20 AM »
Mhhh compiled last version, correct version of SDL mixer. It can be because it still uses OSS? (there is no debug warning of /dev/dsp busy, but who knows) I also installed the 32bit libraries, just in case... still no luck!

vladimir

  • Guest
Re: No music (Yeah, sdl instaled as music placed on the dir)
« Reply #4 on: September 30, 2012, 05:28:35 PM »
Quote from: "vladimir"
Mhhh compiled last version, correct version of SDL mixer. It can be because it still uses OSS? (there is no debug warning of /dev/dsp busy, but who knows) I also installed the 32bit libraries, just in case... still no luck!


Ok, so this is terribly retarded... I had the volume set to "0" :heh: . I swear it wasn't the first time I posted this problem, or when I reinstalled the first time the game, however whatever it is, at least in Arch, if you take care of installing the 32 bit libs, SDL and the music, it will work. However I am quite sad I coudn't figure out why that wasn't working some months ago...

Cthulhu

  • Ace
  • *****
  • Posts: 1371
    • View Profile
Re: No music (Yeah, sdl instaled as music placed on the dir)
« Reply #5 on: October 09, 2012, 08:54:31 AM »
Ha!
 :eeeee: