Laserbrain Studios

Games Forum Blog Contact

Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Message icon:

Please enter the missing word of the game title "Hidden _______":

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Christian Knudsen
« on: January 19, 2017, 02:45:19 PM »

Yeah, I don't really have any further ideas. The only solution may just be to install another distro, but there's no guarantee that would fix it, so might be a lot of work for naught.
Posted by: Jack
« on: January 16, 2017, 09:10:03 PM »

I tried to use xenial, but the new driver was depending on a new xorg, which wasn't available.

I used deb trusty main but it is empty. Every distribution below xenial seems to be empty.

Another idea would be to compile the packages on my own, but I am sure, I don't want to. If I compile a new driver, I may need a new Xorg. The new Xorg may need a new glib or a new compiler. The new compiler could be available in LTS with gcc-mozilla but in the end I have a linux from scratch.

If you have another idea, I can try it. If I have enough free time, I will install another distro.
Posted by: Jack
« on: January 16, 2017, 05:11:19 PM »

I just tested to uninstall the linux-firmware-nonfree, because there is a blob to accelerate the GPU, but nothing changed.
The next step will be the repository.

21.608384] radeon 0000:01:00.0: firmware: failed to load radeon/R100_cp.bin (-2)
[   21.608440] radeon 0000:01:00.0: Direct firmware load failed with error -2
[   21.608449] radeon 0000:01:00.0: Falling back to user helper
[   21.634260] [drm:r100_cp_init] *ERROR* Failed to load firmware!
[   21.634317] radeon 0000:01:00.0: failed initializing CP (-12).
[   21.634359] radeon 0000:01:00.0: Disabling GPU acceleration
[   21.634401] [drm] radeon: cp finalized
[   21.634479] [drm] radeon: cp finalized
Posted by: Christian Knudsen
« on: January 16, 2017, 10:45:55 AM »

OpenGL 1.3 should be fine. I believe 1.1 is the minimum requirement for Ascii Sector.

Another user with the same problem ended up installing the MESA driver from this repository:

That resulted in something being drawn on screen, but flickering to the point that it was still unplayable. We had to give up at that point, since some more investigation from the user resulted in it seemingly being a driver issue and not something I could fix in code. Maybe you'll have more luck with the driver from that repo?
Posted by: Jack
« on: January 15, 2017, 07:29:54 PM »

Is my hardware outdated with OpenGL 1.3? :
3D Core    Engineering Names           Shader Model    DX    OpenGL    Max Texture Size    Max Renderbuffer Size
R1xx    R100, RV100, RV200, RS100, RS200    NA          7    1.3          2048               2048

direct rendering: Yes
OpenGL renderer string: Mesa DRI R100 (RV100 4C59) x86/MMX/SSE2 NO-TCL DRI2
OpenGL version string: 1.3 Mesa 8.0.5
Posted by: Jack
« on: January 15, 2017, 05:54:01 PM »

I realized, that I started the old kernel, but nothing changes, if I start the new one.
My packages are up to date.

lspci -vs01:00.0
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV100 LY [Mo
bility Radeon 7000] (prog-if 00 [VGA controller])
        Subsystem: IBM Device 052f
        Flags: bus master, stepping, fast Back2Back, 66MHz, medium devsel, latency 6
6, IRQ 11
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at c0120000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
        Kernel driver in use: radeon

uname -a
Linux hostname 3.16.0-0.bpo.4-586 #1 Debian 3.16.36-1+deb8u2~bpo70+1 (2016-10-19) i686 GNU/Linux

i     libgl1-mesa-glx                                  8.0.5-4+deb7u2 8.0.5-4+deb7u2
Posted by: Christian Knudsen
« on: January 15, 2017, 10:50:48 AM »

Seems like it might be an OpenGL issue. Have you tried updating your graphics driver to the newest version (if possible)?
Posted by: Jack
« on: January 14, 2017, 08:02:11 PM »

If I start ./asciisec I get a black window and nothing happens. I use Debian Wheezy. I also installed sdl 1.2. Is that a problem?
i     libsdl2-2.0-0 2.0.0+dfsg1-2~
i     libsdl2-image-2.0-0 2.0.0+dfsg-3~b
i     libsdl2-mixer-2.0-0 2.0.0+dfsg1-5~

$ cat log.txt
SDL video initialized.
SDL timer initialized.
SDL audio initialized.
Opening audio...
Loading sounds...
Setting video mode...
Setting up OpenGL...
Loading font map...

$ cat options.txt

Posted by: Christian Knudsen
« on: December 08, 2016, 01:15:11 PM »

No error message when running from terminal either?

(Navigate to the asciisec folder and run it with ./asciisec)
Posted by: bikimaru
« on: December 07, 2016, 05:42:04 PM »

hi all,

new user, old gamer.
wasn't sure if this was the right place to post this but...
i've been playing ascii sector for a few years now in windows and have recently moved to linux using lubuntu 16.10
i downloaded the linux file from the download page and tried running the executable but it doesnt do anything.
no error messages or anything.
ive searched for some solutions but none of them seem to work.
ive made sure that i have the needed sdl packages to run the game too.
hope you can help, thanks in advance.