Laserbrain Studios

Games Forum Blog Contact

Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Message icon:

Please enter the missing word of the game title "Hidden _______":

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Sotne
« on: April 21, 2018, 10:59:27 PM »

I got a way to execute it, running this command: MESA_GL_VERSION_OVERRIDE=2.1 ./asciisec

For some reason the game does not detect correctly that I'm using OpenGL 2.1, although I have to use a program called Driconf for enable it because it uses OGL 1.4 by default.

Thanks for the help.
Posted by: Sotne
« on: April 21, 2018, 07:19:15 PM »

I can't upgrade my drivers even more, I use practically the latest version available because Manjaro is a Rolling Release, and I don't think that making a downgrade would easy for me because of the way the package manager works. Do you think that viewing the OpenGL extensions can help?
Posted by: Christian Knudsen
« on: April 21, 2018, 12:37:32 PM »

The game is compiled against SDL2, so if you have all those libraries installed, that shouldn't be the problem. Since you get the same issue when running the Windows version in WINE, I suspect it's an issue with your graphics driver not playing well with the game's OpenGL. Can you try to update (or maybe downgrade) your graphics driver?
Posted by: Sotne
« on: April 21, 2018, 04:46:29 AM »

Hi, I've been trying to run the game on Manjaro Linux, but the game goes blank while it's loading and does nothing. This is log.txt content:

SDL video initialized.
SDL timer initialized.
SDL audio initialized.
Opening audio...
Loading sounds...
Setting video mode...
Setting up OpenGL...
Loading font map...

I ran the game with GDB and this is what I got:

Starting program: /XXXX/XXXX/asciisec
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".
[New Thread 0x7ffff00af700 (LWP 3155)]
                                      [New Thread 0x7ffff7f67700 (LWP 3156)]
                                                                            [New Thread 0x7fffde1ed700 (LWP 3157)]
                                                                                                                  [Thread 0x7fffde1ed700 (LWP 3157) exited]
                              [Thread 0x7ffff7f67700 (LWP 3156) exited]
                                                                       [Thread 0x7ffff00af700 (LWP 3155) exited]
[Inferior 1 (process 3151) exited normally]

I close it with Alt + F4.

This is options.txt content:



And this what inxi -CG shows when I run it, in case it's useful:

CPU:       Topology: Single Core model: Intel Atom N455 type: MT L2 cache: 512 KiB
           Speed: 997 MHz min/max: 1000/1667 MHz Core speeds (MHz): 1: 997 2: 998
Graphics:  Card-1: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics driver: i915 v: kernel
           Display Server: x11 (X.Org 1.19.6) driver: intel resolution: 1024x600~60Hz
           OpenGL: renderer: Mesa DRI Intel Pineview M v: 1.4 Mesa 18.0.0

I tried to run the Windows version using Wine and it did not work either, the same thing happened.

Something that occurs me is that the game is compiled against old libraries and this causes some problems, maybe it could be solved if it's recompiled in an more modern system, or an AppImage file could be made for the game so it has less problems for run on any Linux system.

Thanks in advance for any assistance and sorry for my bad English.